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Mail Merge with 4HPlus! and Microsoft Word

A mail merge file can be created in the 4HPIlus! program and used to send letters
to the members and/or leaders. This is done through the mail merge feature in
Microsoft Word. The examples are using Microsoft Office XP or Office 2003, and
Windows XP.

Mail merge is also used to create e-mail messages, envelopes, labels, and
directories. Name badges can be created by using labels and selecting the Avery 5095

Name badge label option.

Create the Mail Merge File

Use the SQL feature in 4HPIlus! to create a mail merge file to send letters to
members and/or leaders. In this example, a letter is being sent to all members
welcoming them to the new 4-H year. The letter shows the member’s personal
information and asks them to confirm it is correct. It also includes a request for their
e-mail address, if they have one available.

1. Open the 4HPIlus! program.
2. Click Goto > Members > SQL > Request > Mail Merge.

Note: Use the current year field to select the current members.

Check the Current Year check box on the Build Mail Merge File screen.
Click the (=) Equal to radio button in the Operator box.

A box showing a list of years displays. Highlight the current year.

Click the Continue button.

A Connector box displays. Click the Process radio button.
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Note: The number of matches for the query displays. Make sure data is

available, and the number of matches is not zero.

8. Next, the Select print fields in print order screen displays. See Figure 1.

Wyoming Washakie Structured Query Language Data... Data Set 2002/2002

Exit Request Queus Setup Email

Fequest ...

Clear field selection |

Build Mail Merge File: Members with "Current Year'' = 02"

Matches...
B4,/242
Select print figlds in print order....
[~ Id [~ S5N
1 v Last g v DOE
2 | First [~ Age
[T ML [T Gender
3 v Sheet |~ Race 10
4 |w Citp |7 Hesidence
E |v State [T Grade
B v Zip 9 v School Mame
7 |¥ Phone [ 4H'vVears
[~ &l Phone [~ Current v'ear

Continue [zelect sort order]

Hint: The field selection, target matching, etc. for pour Mail-menge request is now A
complated. At this time pou must select the figlds that pou wish the SOL mail-merge
generator to zave in your mai-merge file. You do not have to [but you can) zave

|the zame fields you uzed to control your recaord zelection. In what order do they get

o

i [~ Other
I I
i I
|| i

7 Units
T [ Projects
|7 Parent / Gua BE
[ Active |_|
[~ Leadership ™
[~ Parenting

Figure 1. Select Print Fields

9. Click the check box for these fields.

Last
First
Street
City
State

Zip

Phone

DOB

School Name

E-mail Address

10. Click the Continue (select sort order) button.

11. At the Select Sort Order screen, check Last so it sorts on the last name. The

number 1 appears to the left of the field name showing it is the primary sort.

12. Check First so it performs a secondary sort on the first name. The number 2

displays to the left of the field name.
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13.
14.

Click the Process My Request! button.

An information window displays with the message, “Task Completed! Merge Fields
are in file C:\CKV\4HPIus\Wy\Files\4HPMail.dat.” Make a note of the file location.
Click OK.

SQL Request

Once the SQL request is completed, it can be saved to be used again in the

future.

1.

o > D

Click Queue > Add. The SQL request criterion displays.
Type Current Members in the Name Request field.
Press the tab key.

Click the Add Now button.

Click the Return button.

Mail Merge Wizard

The member information is used in a mail merge to send the letter. The data is

merged using the Mail Merge Wizard.

1.
2.

© ® N o g~

Open the Microsoft Word program.
Open a new document.
Note: The examples are shown in print layout view. Click View > Print Layout

to change the view, if needed.

Click Tools > Letters and Mailings > Mail Merge Wizard. The task pane with the
Mail Merge wizard displays on the right-hand side of the screen. See Figure 2 on
page 4.

Select the document type by clicking the Letters radio button.

Click the Next: Starting document link.

Click the Use the current document radio button.

Click the Next: Select recipients link.

Click the Use an existing list radio button.
Under the Use an existing list section, click the Browse link. The Select Data

Source window displays.
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Figure 2. Mail Merge Wizard

10. Navigate to the 4HMail file located in the C:\CKW\4HPIus\WY/Files folder, and
open it. The Mail Merge Recipients window displays. See Figure 3 on page 5.
11. Click the Select All button, and click OK.

Note: The path for the 4HMail file displays in the Use an existing list section.

12. Click the Next: Write your letter link.
Note: Click the Show/Hide ] icon so the paragraph and tab marks display while

inserting fields in the letter. Displaying the icon makes it easier to place the fields

in the letter.

13. Click Insert > Date and Time to show the current date. The Date and Time dialog
box displays.

14. Highlight the desired date format.

15. Check the Update automatically box.

16. Click OK.

17. Press Enter three times to leave space in-between the date and the address block.
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Mail Merge Recipients

To sark the lisk, click the appropriate column heading, To narrow down the recipients displayed by a
specific criteria, such as by city, click the arrow next ko the column heading, Use the check boxes or
buttans ko add ar remove recipients From the mail merge.,

List af recipients:

| v Last| * First | v city | *| state | 1 z..] ¥/ Email_address
Ander... Charley Worland WY (307734
ander...  Chris Warland WY (307334
Ander...  Sammy Wearland WY (307134
Barnes Kristi Wearland W (307334
Bastida  Roman Worland WY (307734
Batts Diana Tensl... WY whb3s3@vahoo.com (30703
Bennett  Elizabeth Wearland WY speedracer_ret@wah... (307)34
Bush Myles Tensl... Wy (307336
Casdo.,. Eatie Worland WY (307734
Chrisk...  Erik Worland WY echris@trib.com (307734
i~ hrict Sara Winkland Wy erhrickimitrib o 3N7h3%d

¥

W

A JRIEREREREEEE

Select Al | Clear all | Refresh

Find. .. | Edit... | Walidate

Figure 3. Mail Merge Recipients

18.

19.

20.

21.

22.

23.

24.

25.

26.

Click the Address Block link in the Write your letter section. The Address Block
dialog box displays.

Click the Match Fields button to display how the fields are matched between the
4-H mail merge file and Word mail merge. The Address 1 field is not available.
See Figure 4 on page 6.

Click the Address 1 field arrow. A list of the fields from the 4-H data displays.
Highlight Street to match it with the Address 1 field.

Click OK. The Address Block dialog box displays.

Highlight Joshua Randall Jr. under the Insert recipient’s name in this format
section.

Because a company name is not used with 4-H, click the Insert company name
box to uncheck it.

Check the radio button for Never include the country/region in the address in
the Insert postal address section.

Look at the Preview field to see if the address is in the desired format. Make

changes as needed.
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27.

Click OK. The wording <<AddressBlock>> displays in the letter.

Match Fields

Mail Merge has special features For easily working with addresses. Please specify address
field components ko simplify address insertion,

Required information -
Last Mame |Last j
Fist Marme [ Firsk - |
Courkesy Title [(rot available)  « |
Caompany |{n-:ut available) ﬂ
Address 1 [(rot available) - |
City [ ity - |
Skate [State |
Postal Code [Zip |
Spouse Firsk Mame |(n-:|t available) j

Optional information
Middle Mare [frot available) = |
1 FFi [femk susilabla? |

IJse the drop-down lists o choose the Field from wour database that corresponds to the
address information Mail Merge expects (lisked on the left,)
Cancel

Figure 4 - Match Fields

28.

29.
30.

31.

32.

Press Enter three times to add blank lines in-between the address block and the
salutation.

Click the Greeting line link. See Figure 5 on page 7.

Click the down arrow next to Mr. Randall. Scroll down and select the greeting for
Joshua or Josh.

Look at the Preview field to see if the greeting is in the desired format. Make
changes as needed.

Click OK. The wording <<GreetingLine>> displays in the letter.
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Greeting Line

Greeting line farmat:
|Dear d IJl:nshua ;I |, _"J

areeting line far invalid recipient names;
IDear Sir ar Madarn, ;I

Presiew

Dear Joshua,

Ik Cancel

Figure 5. Greeting Line

33. Type the rest of the letter. See the sample letter in Figure 6.

2l Document3 (Preview) - Microsoft Wond

File Edit Wew Insert Format Tools  Table  window  Help insert graphics -
=1 E BB s - Close | K2 |
o S 1+ 123 a s S &

VWelcome to 2002 and a new year in 4-H! We hope you enjoyed your projects
lastyear and we are looking forward to warking with you this vear.

We have a new service available to you. You can receive the monthly 4-H
newesletter thraugh your e-mail. If you have access to e-mail and would like to
receive the newsletter this way, please write your e-mail address on this letter
and give itta your leader. Also please et us know if any other corrections need
to be made to your personal infarmation. If anything needs to be corrected,
please contact vour leader. You may also call aur office at 721-2571 with the
corrections.

Have a greatyear!

Sincerely,

E John Smith
o 4-H and Youth Educatar

Mame:
Address:

3 Phone kumber:
- Birthday:
School:

Page 1 Sec 1 11 ak 1" Lnl  call PEC TRK EXT OVR Endishius G

Figure 6. Sample Letter

34. Member information is added after the signature block. Take the following steps to
add the fields.
35. Type Name:, and press the tab key.
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36. In the Mail Merge task pane, click the More items link. The Insert Merge Field
dialog box displays. See Figure 7.

37. Click the Database Fields radio button.

38. Highlight First for the first name, and click the Insert button.

39. Click the Close button. The field <<First>> displays on the letter.

-
Insert Merge Field

Inzert:
" Address Fields {* Database Fields

Fields:

Last

Skreet

ity

Skake

Zip

Phone

DB
School_Mame
Email_address

=
Match Fields. .. | Insert | Zancel |

Figure 7 - Insert Merge Field

40. Press the spacebar to add a space after <<First>>.
41. Click the More items link.

42. Highlight Last for the last name, and click Insert.
43. Click the Close button.

44. Press the Enter key.

45. To insert the address, type the word Address:, and press the tab key.
46. Click the More items link.

47. Highlight Street, and click Insert.

48. Click the Close button.

49. Add a space after <<Street>>.

50. Click the More items link.
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51. Highlight City, and click Insert.

52. Click the Close button.

53. Add a space after <<City>>.

54. Click the More items link.

55. Highlight State, and click Insert.

56. Add a space after <<State>>.

57. Press the Enter key.

58. Click the More items link.

59. Highlight Zip, and click Insert.

60. Click the Close button.

61. Type Phone Number: on the next line and press the tab key.

62. Click the More Items link.

63. Highlight Phone, and click Insert.

64. Click the Close button.

65. Press the Enter key.

66. Repeat the process for the birthday, school, and e-mail address items. See

Figure 8 for the final letter.

Note: Align the information by changing the tab setting. Highlight the personal
information. Be sure the left tab icon displays on the ruler. Click at 1 2" mark on

the ruler.
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izl 4H Letter Mail Merge (Preview) - Microsoft Word

- File Edit iew
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Format  Tools  Table ‘window  Help
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N

October 23, 2002

wotddressBlo iz

oo 3 reetin glines »

e leome to 2002 and a nev year in EH! e hope you enjoyed your proje cts
last year and we are looking fonmand to womking with wou this year.

e hawve a newsenrice available to you. “ou can receive the monthly 4H
nevelettarthough your e-mail. §you hawe aecess to e-mail and wwould like to
receive the neweletter this way, please wite your e-mail address on this lether
and give itto vourleader. Alzo please let us know if any other corecions need
to be made to your personal information. If armthing needs to be corected,
pleaze contact yourleader. “ou may also call our office at 721-257 1 with the
corrections.

Have a great yead

Sincarely,

Jahn Smith

4-H and “vouth Educator

Mame: wFirsts olasts

Address: wStreets «Cibye oStaten ofips
Phone Humber: «Phones

Bithday: «D OB

School: wSchool_Mames

E-mail Address: «Email_Address.

3

11 ak 11" Lnz  Cold REC TRE EXT OVE Englshius G

|Wednesday, ctober 23, 2002

Figure 8 - Final Letter

67. Click the Next: Preview your letters link. The letter displays with the information.

68.
69.
70.
71.
72.

Review it to be sure everything is correct. Click the arrow buttons to review

additional letters.

Note: Changes can be made to the letter or to the data. Click the Previous:

Write your letter link to make changes to the letter. Click the Previous: Select

recipients link and the Edit recipient list link to make changes to the data.

Click the Next: Complete the merge link. Two options are available.

Click the Print link to print the letters.

Click the Edit individual letters link to make changes to individual letters.

Click File > Save As to save the letters.

Type the file name, and click the Save button.
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Use the Current Members Saved Request

The current members request can be used again to create another mail merge
file. It uses the same criteria as originally created. Create a new request when different
criterion is needed.

1. Click Goto > Members > SQL > Queue > Display.
A list of the saved SQL requests displays.
Highlight the Current Members request. The request criterion displays.
Click the Process button to run the request.

Click OK at the information message.

2B

Click Exit > Goto > Exit to close the program.
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