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4.1.4. The Session Window 

Once you have opened or created a session (see "4.1.3. Creating and Opening Sessions" on page 22), a 

session window displays for the session you are working with: 

 

The session window contains all the screens used by the session. 

If additional windows are open in the IECM, they may be behind the new session window.  If you want 

to switch to another window that is partially visible, you may click on it to bring it to the front. If the 

window is completely hidden, you will need to use Alt-Tab or the taskbar to switch to it. (See 

"2.7.1. Switching Applications or Windows" on page 7.) 

4.1.4.1. The Session Window Menu Bar 

Like the main window, the session window has a menu bar. It consists of four pull-down menus: 

"File" "Edit", "Go" and "Help". These pull-down menus issue commands to the IECM software. 

4.1.4.1.1. The File Menu 

The "File" menu is the left-most pull-down menu on the menu bar: 

Illustration 33: An IECM Session Window 

NOTE: This is an excerpt from the User Manual which may be helpful in understanding
the difference between the old interface shown in the videos and the current interface.
The full User Manual comes with the IECM and is also available on the Download page
on our website.
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Some of the commands are the same as those available in the "File" menu on the main window. 

See "4.1.2.1.1. The File Menu" on page 20, for a description of these commands. 

The "File" menu on a session window contains the following additional commands: 

• Save: Saves the current session in place. (See "4.1.5.2. Save" on page 41.) 

• Save As...: Saves the current session with a different name and/or in a different database. 

(See "4.1.5.3. Save As" on page 41.) 

• Export: Exports data from the current session. 

• Print preview...: Shows what would be printed with the Print command. 

• Print...: Prints the current screen. 

• Close Window: Closes the current session. You will be prompted to save the session if 

changes have been made since your last save. (See "4.1.6. Closing Sessions" on page 

42.) 

4.1.4.1.1.1. The Export Menu 

The Export menu is accessed from the Export command on the File menu: 

 
Illustration 34: The Session Window File Menu 
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You may choose the following commands from this menu: 

• Export Changed Parameters: Exports all parameters that have been changed from 

their default values. 

• Export All Parameters: Exports all parameters. 

• Export Results: Exports all results. 

• Export Samples: Exports all samples. 

We recommend viewing the output from these commands in a spreadsheet. 

4.1.4.1.2. The Edit Menu 

The "Edit" menu is the second pull-down menu on the menu bar: 

 

The "Edit" menu contains commands for working with the clipboard. (See "2.6. Using the 

Clipboard" on page 6.) You may choose the following commands from this menu: 

• Cut: Copies the current selection to the clipboard and deletes it. 

• Copy: Copies the current selection and does not delete it. 

 
Illustration 35: The Export Sub-Menu 

Illustration 36: The Session Window Edit Menu 
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• Paste: If there is a current selection, it is replaced by the contents of the clipboard; 

otherwise, the contents of the clipboard is inserted at the current cursor position. 

• Copy Window as Bitmap: A bitmap image representing the current window is copied to 

the clipboard. 

• Copy Window as Text: A text representation of the current window is copied to the 

clipboard. 

4.1.4.1.3. The Go Menu 

The "Go" menu is the third pull-down menu on the Menu bar: 

 

You may choose the following commands from this menu: 

• Previous Screen: Goes to the previous screen in the navigation panel. (See "4.1.4.4. The 

Navigation Panel" on page 33.) 

• Next Screen: Goes to the next screen in the navigation panel. (See "4.1.4.4. The 

Navigation Panel" on page 33.) 

• Back in History: Goes to the previous screen in the history. This is not currently 

implemented. 

• Forward in History: Goes to the next screen in the history. This is not currently 

implemented. 

• Expand All...: Expands the entire navigation panel. (See "4.1.4.4. The Navigation 

Panel" on page 33.) 

4.1.4.1.4. The Help Menu 

The Help menu is the fourth pull-down menu on the Menu bar: 

 

This is the same as the "Help" menu on the main window. (See “4.1.2.1.2. The Help Menu” on 

page 21.) 

 
Illustration 37: The Session Window Go Menu 

 
Illustration 38: The Session Window Help Menu 
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4.1.4.2. The Session Window Toolbar 

Like the main window, the session window has a toolbar. (See "4.1.2.2. The Main Window Toolbar" 

on page 21.) However, the session window's toolbar has much more content: 

 

The following items appear on the toolbar, from left to right: 

4.1.4.2.1. The "New Session" Button 

 

The first button on the left creates a new session. It corresponds to the "New Session" command 

in the "File" Menu. (See "4.1.2.1.1. The File Menu" on page 20, and “4.1.3.1. Creating a New 

Session from Model Defaults” on page 22.) 

4.1.4.2.2. The "Open Session" Button 

 

The second button from the left opens a previously-saved session. It corresponds to the "Open 

Session" command in the "File" Menu. (See "4.1.2.1.1. The File Menu" on page 20, and 

"4.1.3.2. Opening an Existing Session" on page 23.) 

4.1.4.2.3. The "Save Session" Button 

 

The third button from the left saves the current session. It corresponds to the "Save" command in 

the "File" Menu. (See "4.1.2.1.1. The File Menu" on page 20, and "4.1.5.2. Save" on page 41.) 

4.1.4.2.4. The "Save Session As" Button 

 

The fourth button from the left saves a copy of the current session. It corresponds to the "Save 

As..." command in the "File" Menu. (See "4.1.2.1.1. The File Menu" on page 20, and 

"4.1.5.3. Save As" on page 41.) 

Illustration 39: The Session Window's Toolbar 

 
Illustration 40: The "New Session" Button 

 
Illustration 41: The "Open Session" Button 

 
Illustration 42: The "Save Session" Button 

 
Illustration 43: The "Save Session As..." Button 
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4.1.4.2.5. The "Go to Previous Screen" Button 

 

The fifth button from the left moves to the previous screen in the navigation panel. It corresponds 

to the "Previous Screen" command in the "Go" Menu. (See "4.1.4.4. The Navigation Panel" on 

page 33.) 

4.1.4.2.6. The "Go to Next Screen" Button 

 

The sixth button from the left moves to the next screen in the navigation panel. It corresponds to 

the "Next Screen" command in the "Go" Menu. (See "4.1.4.4. The Navigation Panel" on page 

33.) 

4.1.4.2.7. The "Go to Previous Screen in History" Button 

 

The seventh button from the left is currently not implemented. It corresponds to the "Back in 

History" command in the "Go" Menu. (See "4.1.4.1.3. The Go Menu" on page 30.) 

4.1.4.2.8. The "Go to Next Screen in History" Button 

 

The eighth button from the left is currently not implemented. It corresponds to the "Forward in 

History" command in the "Go" Menu. (See "4.1.4.1.3. The Go Menu" on page 30) 

4.1.4.2.9. The Location of the Current Screen 

 

The text in the middle of the toolbar between sets of buttons shows the location of the current 

screen in the navigation panel. (See "4.1.4.4. The Navigation Panel" on page 33.) Different levels 

 
Illustration 44: The "Go to Previous Screen" Button 

 
Illustration 45: The "Go to Next Screen" Button 

 
Illustration 46: The "Go to Previous Screen in History" Button 

 
Illustration 47: The "Go to Next Screen in History" Button 

 
Illustration 48: The Location of the Current Screen 
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are separated by a colon. In this case, we're in the "CONFIGURE SESSION" section, on the 

"Plant Design" screen. 

4.1.4.2.10. The "Close Window" Button 

 

The second button from the right closes the current session window, prompting the user to save 

any unsaved changes. It corresponds to the "Close Window" command in the "File" Menu. (See 

"4.1.4.1.1. The File Menu" on page 27, and "4.1.6. Closing Sessions" on page 42.) 

4.1.4.2.11. The "Exit" Button 

 

The button all the way on the right closes all session windows, prompting the user to save any 

unsaved changes, and exits the IECM. It corresponds to the "Exit" command in the "File" Menu. 

(See "4.1.2.1.1. The File Menu" on page 20, and "4.1.9. Exiting the IECM Interface" on page 44.) 

4.1.4.3. The Status Bar 

The session window has a status bar along the bottom edge: 

 

The status bar is divided into three parts. The left side shows descriptions of menu commands. If 

you pull down one of the menus in the menu bar and hold the mouse pointer over a command, a 

brief description of that command appears in the status bar. 

The center shows this reminder: "(Right-click values for more options.)" 

The right side contains a note indicating whether constant or current dollars are used, along with the 

cost year. This applies to all costs displayed in the IECM. These parameters may be set on the 

overall plant financing input screen, described in "5.2.2.1.5. Financing & Cost Year" on page 119. 

4.1.4.4. The Navigation Panel 

Movement within the interface is accomplished primarily through the use of the navigation panel, 

which sits on the left side of the session window: 

 
Illustration 49: The "Close Window" Button 

 
Illustration 50: The "Exit" Button 

 
Illustration 51: The Session Window Status Bar 
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4.1.4.4.1. How to Use the Navigation Panel 

To use the navigation panel, locate the item you wish to view and click on it. 

Items which contain other items have a small box containing either a "+" or a "–" to the left of the 

title. The "+" indicates that there is content which is not shown; the "–" indicates that there is 

content which may be hidden. Click the box to expand or hide the content, or use the "Expand 

All" command in the "Go" menu to show all the content. (See "4.1.4.1.3. The Go Menu" on page 

30.) Note that you cannot hide the screen currently being displayed. 

For example, in the illustration above (Illustration 51: The Session Window Status Bar on page 

33), the "CONFIGURE SESSION" section has been expanded to show its content: "Plant 

Design", "Plant Location", and "Unit Systems". The other sections have not been expanded, and 

their content is not currently visible. 

Items which contain other items do not have screens associated with them. Clicking on one of 

these items will take you to the first screen contained within that item. 

For example, clicking on "SET PARAMETERS" in the illustration above (Illustration 51: The 

Session Window Status Bar on page 33) produces the following result: 

 
Illustration 52: The Navigation Panel 
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When "SET PARAMETERS" was clicked, the IECM expanded it and went to the first sub-item, 

"Overall Plant". "Overall Plant" contains other items, so the IECM expanded it and went to its 

first sub-item, "Diagram". "Diagram" does not contain any other items; it is a screen, so the 

IECM displays it. The current location on the toolbar (see "4.1.4.2.9. The Location of the Current 

Screen" on page 32) changes to reflect this: 

 

4.1.4.4.2. Organization of the Navigation Panel 

This section describes how the contents of the navigation panel are organized. 

Older versions of the interface, which you may encounter in older documentation and videos, 

used tabs. Although the new navigation panel looks different, the structure is essentially the same, 

and we use the same terms to describe it.. The relationship between the old tabs and the new 

navigation panel will be briefly described here and in the following section (see "4.1.4.2.9. The 

Location of the Current Screen" on page 32) to aid in understanding these older resources. 

4.1.4.4.2.1. Program Areas 

 
Illustration 53: Clicking "SET PARAMETERS" in the Navigation Panel 

 
Illustration 54: Location after Clicking "SET PARAMETERS" 
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Each session contains 4 program areas: "CONFIGURE SESSION", "SET PARAMETERS", 

"GET RESULTS" and "ANALYSIS TOOLS": 

 

In the old tab-style interface, the program areas are in the row of large tabs at the top of the 

session window. 

4.1.4.4.2.2. Technologies 

Inside each program area, the screens are grouped by technology. In the old tab-style interface, 

technologies are in the row of smaller tabs beneath the program areas. 

"CONFIGURE SESSION" has no technologies, as none of its screens are technology-specific. 

"ANALYSIS TOOLS" contains 2 technologies: "Sensitivity Analysis" and "Uncertainty". 

The list of technologies in "SET PARAMETERS" and "GET RESULTS" is different for each 

plant type. Technologies that do not contain any screens in the current configuration will not be 

shown. 

4.1.4.4.2.2.1. Technologies in a Pulverized Coal (PC) Plant 

The "SET PARAMETERS" and "GET RESULTS" program areas in a PC plant may contain 

the following technologies: 

• Overall Plant 

• Fuel 

• Base Plant 

• NOx Control 

• Mercury 

• TSP Control 

• SO2 Control 

• CO2 Capture, Transport & Storage 

• Water Systems 

• By-Prod. Mgmt 

• Stack 

• Water Life Cycle Assessment 

4.1.4.4.2.2.2. Technologies in a Natural Gas Combined Cycle (NGCC) Plant 

 
Illustration 55: Program Areas 
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The "SET PARAMETERS" and "GET RESULTS" program areas in an NGCC plant may 

contain the following technologies: 

• Overall Plant 

• Fuel 

• Power Block 

• NOx Control 

• CO2 Capture, Transport & Storage 

• Water Systems 

• By-Prod. Mgmt 

• Stack 

• Water Life Cycle Assessment 

4.1.4.4.2.2.3. Technologies in an Integrated Gasification Combined Cycle (IGCC) Plant 

The "SET PARAMETERS" and "GET RESULTS" program areas in an IGCC plant may 

contain the following technologies: 

• Overall Plant 

• Fuel 

• Air Separation Unit 

• Gasifier Area 

• Sulfur Removal 

• CO2 Capture Transport & Storage 

• Power Block 

• Water Systems 

• By-Prod. Mgmt 

• Stack 

4.1.4.4.2.2.4. An Example: Technologies in a Typical New PC Plant 

As an example, this illustration shows the technologies available under "SET 

PARAMETERS" in a PC plant with the "Typical New Plant" configuration: 

 

 
Illustration 56: "SET PARAMETERS" in a Typical New PC Plant 
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You may notice that "CO2 Capture, Transport & Storage" is missing. That is because this 

configuration does not include CO2 capture. 

These are the technologies available under "GET RESULTS" for the same configuration: 

 

This list is slightly different from the "SET PARAMETERS" list. In particular, "Stack" only 

appears in "GET RESULTS". The "Stack" module does not have any parameters, only 

results, so it is hidden in "SET PARAMETERS". 

4.1.4.4.2.3. Process Types 

Your plant may have more than one process that falls into the same "technology" category. In 

this case, the screens in the affected technologies will be grouped by process type. This 

corresponds to the "Process Type" menu which is located in the lower left part of the screen, 

just above the bottom row of tabs, in the old tab-style interface. 

For example, in the Typical New PC plant we've been looking at, the "NOx Control" 

technology has two different process types: "In-Furnace Controls" and "Hot-Side SCR". These 

are the "NOx Control" screens available in the "SET PARAMETERS" program area: 

 

If we go to the "CONFIGURE SESSION: Plant Design" screen and remove the in-furnace 

controls, the list changes: 

 
Illustration 57: "GET RESULTS" in a Typical New PC Plant 

 
Illustration 58: NOx Control with Process Types 
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Since there is now only one process type, "Hot-Side SCR", it is not shown, and the Hot-Side 

SCR screens are shown directly under the "NOx Control" technology. 

4.1.4.4.2.4. Screens 

Screens are the final level of organization in the navigation panel. They correspond to the tabs 

at the bottom of the window (Input and Result tabs) in the old tab-style interface. 

Each screen is a collection of related settings, parameters, diagrams, etc. which you may use to 

set up the model or view your results. Click on the screen you want in the navigation panel to 

display its contents. 

4.1.4.4.3. Organization in the Old Tab-Style Interface 

Older versions of the IECM used a tab-style interface instead of the navigation panel. You may 

encounter this in older documentation or videos. The interface is organized the same way, except 

it uses tabs: 

 
Illustration 59: NOx Control without Process Types 
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Program areas (see "4.1.4.4.2.1. Program Areas" on page 35) are in the large row of tabs at the 

top. Technologies (see "4.1.4.4.2.2. Technologies" on page 36) are in the medium-sized row of 

tabs just under the program areas. Process types (see "4.1.4.4.2.3. Process Types" on page 38) are 

in the menu on the lower left, just above the bottom row of tabs. Screens (see 

"4.1.4.4.2.4. Screens" on page 39) are in the small row of tabs at the bottom. 

Some configuration information, e.g. uncertainty, is in dialogs activated from the "View" menu in 

older versions, which do not have an "ANALYSIS TOOLS" process area. 

Illustration 60: Guide to Navigation in the Old Tab-Style Interface 
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